CVE-2024-8999

Improper Access Control in lunary-ai/lunary

HIGH
7.5
CVSS Score
Published: March 20, 2025 at 10:08 AM UTC
Updated: June 17, 2026 at 08:23 AM UTC
2 products affected across 2 vendorsLunaryLunary

Using lunary-ai/lunary by lunary-ai?

Get instant alerts when new vulnerabilities affect lunary-ai/lunary - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.8%
SSVC
PoC

Description

lunary-ai/lunary version v1.4.25 contains an improper access control vulnerability in the POST /api/v1/data-warehouse/bigquery endpoint. This vulnerability allows any user to export the entire database data by creating a stream to Google BigQuery without proper authentication or authorization. The issue is fixed in version 1.4.26.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.4.26
Affected range stops below 1.4.26, so it looks safe — our inference, not a vendor statement
v < 1.4.26
Affected range stops below 1.4.26, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCAutomatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-284NVD-CWE-noinfoCWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card