CVE-2024-8756

Quform - WordPress Form Builder <= 2.20.0 - Unauthenticated Sensitive Information Exposure

MEDIUM
5.3
CVSS Score
Published: November 9, 2024 at 05:40 AM UTC
Updated: June 17, 2026 at 08:23 AM UTC
1 product affected across 1 vendorQuform

Using Quform - WordPress Form Builder by ThemeCatcher?

Get instant alerts when new vulnerabilities affect Quform - WordPress Form Builder - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

The Quform - WordPress Form Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.20.0 via the 'saveUploadedFile' function. This makes it possible for unauthenticated attackers to extract sensitive data, such as Personally Identifiable Information, from files uploaded by users. Files uploaded via forms created before version 2.21.0 will remain vulnerable to exposure after upgrading. To fully patch the plugin, site administrators should download any previously uploaded files, delete previously existing files and forms, and create the forms again after upgrading to version 2.21.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Quform· Themecatcherwordpress-plugin
60%
v ≤ 2.20.0

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMWordfence
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card