CVE-2024-8008

Reflected Cross-Site Scripting (XSS) in Multiple WSO2 Products via JDBC User Store Connection Validation

MEDIUM
5.2
CVSS Score
Published: June 2, 2025 at 04:48 PM UTC
Updated: October 16, 2026 at 12:16 PM UTC
10 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Enterprise Integrator by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Enterprise Integrator - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.2
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

A reflected cross-site scripting (XSS) vulnerability exists in multiple WSO2 products due to insufficient output encoding in error messages generated by the JDBC user store connection validation request. A malicious actor can inject a specially crafted payload into the request, causing the browser to execute arbitrary JavaScript in the context of the vulnerable page. This vulnerability may allow UI manipulation, redirection to malicious websites, or data exfiltration from the browser. However, since all session-related sensitive cookies are protected with the httpOnly flag, session hijacking is not possible.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 3.1.0.305, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.396, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.28, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.313, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.182, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.121, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.32, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.16, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
Affected range stops below 6.6.0.211, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
Affected range stops below 5.10.0.328, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.374, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.216, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.201, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.69, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
Affected range stops below 5.10.0.321, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
Affected range stops below 2.0.0.354, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
Affected range stops below 2.0.0.374, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
Affected range stops below 4.5.0.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.14.127.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.17.118.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.17.5.289, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.18.187.276, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.18.248.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.23.8.193, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.24.8.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.25.705.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.25.713.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.25.724.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.25.725 (unaffected)
Affected range stops below 5.25.92.104, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.27.0 (unaffected)
Affected range stops below 7.0.78.46, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.5.12 (unaffected)
Affected range stops below 4.5.0.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.16, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.2MEDIUMWSO2
Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card