CVE-2024-7097

Incorrect Authorization in Multiple WSO2 Products via SOAP Admin Service Allowing Unauthorized User Signup

MEDIUM
4.3
CVSS Score
Published: May 30, 2025 at 03:04 PM UTC
Updated: June 17, 2026 at 08:19 AM UTC
7 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Open Banking AM by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Open Banking AM - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

An incorrect authorization vulnerability exists in multiple WSO2 products due to a flaw in the SOAP admin service, which allows user account creation regardless of the self-registration configuration settings. This vulnerability enables malicious actors to create new user accounts without proper authorization. Exploitation of this flaw could allow an attacker to create multiple low-privileged user accounts, gaining unauthorized access to the system. Additionally, continuous exploitation could lead to system resource exhaustion through mass user creation.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.0.0 ≤ v < 2.0.0.292.1.0 ≤ v < 2.1.0.392.2.0 ≤ v < 2.2.0.562.5.0 ≤ v < 2.5.0.832.6.0 ≤ v < 2.6.0.1423.0.0 ≤ v < 3.0.0.1623.1.0 ≤ v < 3.1.0.2943.2.0 ≤ v < 3.2.0.3843.2.1 ≤ v < 3.2.1.164.0.0 ≤ v < 4.0.0.3054.1.0 ≤ v < 4.1.0.1664.2.0 ≤ v < 4.2.0.1014.3.0 ≤ v < 4.3.0.162.0.02.1.02.2.02.5.02.6.03.0.03.1.03.2.03.2.14.0.04.1.04.2.04.3.0
Affected range stops below 2.0.0.29, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.0.39, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.0.56, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.5.0.83, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.6.0.142, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.0.0.162, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.0.294, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.384, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.305, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.166, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.101, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.16, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
5.10.0 ≤ v < 5.10.0.3185.11.0 ≤ v < 5.11.0.3655.2.0 ≤ v < 5.2.0.325.3.0 ≤ v < 5.3.0.335.4.0 ≤ v < 5.4.0.325.4.1 ≤ v < 5.4.1.365.5.0 ≤ v < 5.5.0.505.6.0 ≤ v < 5.6.0.585.7.0 ≤ v < 5.7.0.1235.8.0 ≤ v < 5.8.0.1065.9.0 ≤ v < 5.9.0.1576.0.0 ≤ v < 6.0.0.2096.1.0 ≤ v < 6.1.0.1887.0.0 ≤ v < 7.0.0.605.10.05.11.05.2.05.3.05.4.05.4.15.5.05.6.05.7.05.8.05.9.06.0.06.1.07.0.0
Affected range stops below 5.10.0.318, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.365, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.0.32, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.0.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.0.32, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.1.36, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5.0.50, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.6.0.58, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.7.0.123, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.8.0.106, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.9.0.157, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.209, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.188, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.60, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.2.0 (unknown)
5.10.0 ≤ v < 5.10.0.3125.3.0 ≤ v < 5.3.0.385.5.0 ≤ v < 5.5.0.515.6.0 ≤ v < 5.6.0.725.7.0 ≤ v < 5.7.0.1225.9.0 ≤ v < 5.9.0.1655.10.05.3.05.5.05.6.05.7.05.9.0
Affected range stops below 5.10.0.312, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.0.38, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5.0.51, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.6.0.72, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.7.0.122, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.9.0.165, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.3.0 (unknown)
1.3.0 ≤ v < 1.3.0.1311.4.0 ≤ v < 1.4.0.1341.5.0 ≤ v < 1.5.0.1362.0.0 ≤ v < 2.0.0.3431.3.01.4.01.5.02.0.0
Affected range stops below 1.3.0.131, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.0.134, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.5.0.136, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.0.343, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.3.0 (unknown)
2.0.0 ≤ v < 2.0.0.3642.0.0
Affected range stops below 2.0.0.364, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
1.3.0 ≤ v < 1.3.0.1141.4.0 ≤ v < 1.4.0.1301.5.0 ≤ v < 1.5.0.1201.3.01.4.01.5.0
Affected range stops below 1.3.0.114, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.0.130, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.5.0.120, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.3.0 (unknown)
2.2.0 ≤ v < 2.2.0.262.2.0
Affected range stops below 2.2.0.26, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMWSO2
Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card