CVE-2024-6832

Account Lockout Failure via Secondary User Store Inaccessibility in Multiple WSO2 Products Allows Brute Force Attacks

HIGH
7.5
CVSS Score
Published: August 6, 2026 at 07:32 AM UTC
Updated: August 9, 2026 at 02:30 PM UTC
10 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Enterprise Integrator by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Enterprise Integrator - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

The account locking mechanism fails to trigger when secondary user stores are inaccessible. The software does not maintain a consistent state for account locking if it cannot reach all configured user stores, allowing an attacker to repeatedly attempt authentication with invalid credentials without triggering the lockout mechanism for users within active stores. When the account locking mechanism is bypassed due to the inaccessibility of secondary user stores, users in accessible user stores are left vulnerable to brute force attacks. A malicious actor can exploit this by attempting numerous invalid password combinations against a user account without the expected account lockout consequence.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.404.6.0 ≤ v < 4.6.0.44.6.0 ≤ v < 4.6.0.54.5.04.6.0
Affected range stops below 4.5.0.40, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.5.0 (unknown)
3.1.0 ≤ v < 3.1.0.2963.2.0 ≤ v < 3.2.0.3863.2.0 ≤ v < 3.2.0.4553.2.1 ≤ v < 3.2.1.744.1.0 ≤ v < 4.1.0.2384.2.0 ≤ v < 4.2.0.1794.3.0 ≤ v < 4.3.0.914.4.0 ≤ v < 4.4.0.554.5.0 ≤ v < 4.5.0.394.6.0 ≤ v < 4.6.0.43.1.03.2.03.2.14.1.04.2.04.3.04.4.04.5.04.6.0
Affected range stops below 3.1.0.296, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.386, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.455, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.74, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.238, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.179, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.91, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.55, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.39, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
5.10.0 ≤ v < 5.10.0.3205.11.0 ≤ v < 5.11.0.4276.0.0 ≤ v < 6.0.0.2546.1.0 ≤ v < 6.1.0.1957.0.0 ≤ v < 7.0.0.825.10.05.11.06.0.06.1.07.0.0
Affected range stops below 5.10.0.320, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.427, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.254, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.195, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.82, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.3145.10.0
Affected range stops below 5.10.0.314, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.3452.0.0
Affected range stops below 2.0.0.345, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.3662.0.0
Affected range stops below 2.0.0.366, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
4.5.0 ≤ v < 4.5.0.384.6.0 ≤ v < 4.6.0.44.6.0 ≤ v < 4.6.0.54.5.04.6.0
Affected range stops below 4.5.0.38, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.5.0 (unknown)
4.5.0 ≤ v < 4.5.0.384.6.0 ≤ v < 4.6.0.44.6.0 ≤ v < 4.6.0.54.5.04.6.0
Affected range stops below 4.5.0.38, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.5.0 (unknown)
4.10.9 ≤ v < 4.10.9.494.5.0 ≤ v < 4.5.0.74.5.3 ≤ v < 4.5.3.534.6.0 ≤ v < 4.6.0.1964.6.1 ≤ v < 4.6.1.1634.6.1 ≤ v < 4.6.1.1644.6.3 ≤ v < 4.6.3.444.6.4 ≤ v < 4.6.4.254.7.1 ≤ v < 4.7.1.774.7.1 ≤ v < 4.7.1.784.8.1 ≤ v < 4.8.1.464.9.26 ≤ v < 4.9.26.334.9.27 ≤ v < 4.9.27.194.9.28 ≤ v < 4.9.28.214.9.33 ≤ v < 4.9.33.44.10.94.5.04.5.34.6.04.6.14.6.34.6.44.7.14.8.14.9.264.9.274.9.284.9.33
Affected range stops below 4.10.9.49, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.3.53, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.196, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.1.163, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.1.164, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.3.44, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.4.25, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.1.77, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.1.78, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.1.46, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.26.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.27.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.28.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.33.4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in x (unaffected)
6.6.0 ≤ v < 6.6.0.2296.6.0
Affected range stops below 6.6.0.229, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-693

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card