CVE-2024-6541

Information Disclosure and Integrity Violation via Improper Message Context Handling in Multiple WSO2 Products

MEDIUM
6.8
CVSS Score
Published: August 6, 2026 at 05:31 PM UTC
Updated: August 31, 2026 at 08:26 PM UTC
4 products affected across 1 vendorAPI ManagerEnterprise IntegratorMicro Integrator

Using WSO2 Micro Integrator by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Micro Integrator - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.8
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The Class Mediator fails to correctly validate or sanitize `messageContext` properties when they are used to populate dynamic values. This allows authenticated users to potentially access or modify data across different system invocations that should be isolated. This weakness can lead to the disclosure of sensitive information belonging to other users or the unintended modification of system data by authenticated users. The exact impact depends on how `messageContext` properties are utilized within the affected WSO2 products.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.2.0 ≤ v < 3.2.0.3943.2.1 ≤ v < 3.2.1.214.0.0 ≤ v < 4.0.0.3114.1.0 ≤ v < 4.1.0.1674.2.0 ≤ v < 4.2.0.1104.3.0 ≤ v < 4.3.0.243.2.03.2.14.0.04.1.04.2.04.3.0
Affected range stops below 3.2.0.394, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.311, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.167, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.110, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.24, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.2.0 (unknown)
6.6.0 ≤ v < 6.6.0.2056.6.0
Affected range stops below 6.6.0.205, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
1.2.0 ≤ v < 1.2.0.1634.1.0 ≤ v < 4.1.0.1034.3.0 ≤ v < 4.3.0.71.2.04.1.04.3.0
Affected range stops below 1.2.0.163, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.103, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.2.0 (unknown)
2.1.7.wso2v143 ≤ v < 2.1.7.wso2v143_1192.1.7.wso2v182 ≤ v < 2.1.7.wso2v182_932.1.7.wso2v183 ≤ v < 2.1.7.wso2v183_622.1.7.wso2v227 ≤ v < 2.1.7.wso2v227_882.1.7.wso2v271 ≤ v < 2.1.7.wso2v271_602.1.7.wso2v319 ≤ v < 2.1.7.wso2v319_74.0.0.wso2v105 ≤ v < 4.0.0.wso2v105_34.0.0.wso2v119 ≤ v < 4.0.0.wso2v119_34.0.0.wso2v20 ≤ v < 4.0.0.wso2v20_632.1.7.wso2v1432.1.7.wso2v1822.1.7.wso2v1832.1.7.wso2v2272.1.7.wso2v2712.1.7.wso2v3194.0.0.wso2v1054.0.0.wso2v1194.0.0.wso2v20
Affected range stops below 2.1.7.wso2v143_119, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v182_93, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v183_62, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v227_88, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v271_60, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7.wso2v319_7, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v105_3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v119_3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.wso2v20_63, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in v4.0.0-wso2v121 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.8MEDIUMWSO2
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card