CVE-2024-58381

PocketMine-MP before 5.11.1 Denial of Service via LoginPacket

HIGH
7.5
CVSS Score
Published: September 9, 2026 at 01:31 PM UTC
Updated: October 27, 2026 at 06:10 PM UTC
1 product affected across 1 vendorPocketMine-MP

Using PocketMine-MP by pmmp?

Get instant alerts when new vulnerabilities affect PocketMine-MP - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

PocketMine-MP before 5.11.1 contains a denial of service vulnerability in LoginPacket JSON processing that allows remote attackers to crash the server by sending malformed JSON data. Attackers can exploit improper object initialization from scalar JSON types to trigger unset required properties, causing the application to crash.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0 ≤ v < 5.11.10
Vendor states this is fixed in 5.11.1 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card