CVE-2024-58241

Bluetooth: hci_core: Disable works on hci_unregister_dev

MEDIUM
5.5
CVSS Score
Published: September 24, 2025 at 11:02 AM UTC
Updated: August 5, 2026 at 12:44 PM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.1%
SSVC
No known exploit

Description

In the Linux kernel, the following vulnerability has been resolved: Bluetooth: hci_core: Disable works on hci_unregister_dev This make use of disable_work_* on hci_unregister_dev since the hci_dev is about to be freed new submissions are not disarable.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≥ 4.19.319v ≥ 5.10.223v ≥ 5.15.164v ≥ 5.4.281v ≥ 6.1.101v ≥ 6.6.42v ≥ 6.9.114.19.319 ≤ v < 4.205.10.223 ≤ v < 5.115.15.164 ≤ v < 5.165.4.281 ≤ v < 5.56.1.101 ≤ v < 6.26.10 ≤ v < 6.11.66.10 ≤ v < 6.126.10.1 ≤ v < 6.11.66.6.42 ≤ v < 6.76.9.11 ≤ v < 6.100d151a103775dd9645c78c97f77d6e2a5298d9133f939bd73fed12dddc2a32a76116c19ca47c76784.19.31948542881997e17b49dc16b93fe910e0cfcf7a9f95.10.2235.15.1645.4.2816.1.1016.106.10 rc76.12 rc16.12 rc26.12 rc36.12 rc46.6.426.9.1196600c2e5ee8213dbab5df1617293d8e847bb4fa9cfc84b1d464cc024286f42a090718f9067b80edd2ce562a5aff1dcd0c50d9808ea825ef90da909fd6cbce18370641a21dd889e8613d8153df15eb39ddeda6ca5f218b668b560d90fc31ae469adbfd92
Vendor states this is fixed in 989fa5171f005ecf63440057218d8aeb1795287d (fixed)
Vendor states this is fixed in cfdb13a54e05eb98d9940cb6d1a13e7f994d811f (fixed)
Affected range stops below 4.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.10 (unaffected)
Vendor states this is fixed in 6.11.6 (unaffected)
Vendor states this is fixed in 6.12 (unaffected)
Affected range stops below 6.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.5MEDIUMCISA-ADP
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card