CVE-2024-53948

Apache Superset: Error verbosity exposes metadata in analytics databases

MEDIUM
5.3
CVSS Score
Published: December 9, 2024 at 01:35 PM UTC
Updated: June 17, 2026 at 08:09 AM UTC
1 product affected across 1 vendorSuperset

Using Apache Superset by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Superset - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

Generation of Error Message Containing analytics metadata Information in Apache Superset. This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.1.0
Affected range stops below 4.1.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMapache
Vector?

Quick Info

StatusANALYZED
CWE
CWE-209

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card