CVE-2024-53847

Trix vulnerable to Cross-site Scripting on copy & paste

MEDIUM
5.1
CVSS Score
Published: December 9, 2024 at 06:49 PM UTC
Updated: June 17, 2026 at 08:09 AM UTC
1 product affected across 1 vendorTrix

Using trix by basecamp?

Get instant alerts when new vulnerabilities affect trix - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.1
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

The Trix rich text editor, prior to versions 2.1.9 and 1.3.3, is vulnerable to cross-site scripting (XSS) + mutation XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.9 or 1.3.3, which uses DOMPurify to sanitize the pasted content.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.3.3v < 2.1.9
Affected range stops below 1.3.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.1MEDIUMGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card