CVE-2024-52797

Searching Opencast may cause a denial of service

HIGH
7.5
CVSS Score
Published: November 21, 2024 at 01:30 AM UTC
Updated: June 17, 2026 at 08:07 AM UTC
2 products affected across 2 vendorsOpencastOpencast

Using opencast by opencast?

Get instant alerts when new vulnerabilities affect opencast - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

Opencast is free and open source software for automated video capture and distribution. First noticed in Opencast 13 and 14, Opencast's Elasticsearch integration may generate syntactically invalid Elasticsearch queries in relation to previously acceptable search queries. From Opencast version 11.4 and newer, Elasticsearch queries are retried a configurable number of times in the case of error to handle temporary losses of connection to Elasticsearch. These invalid queries would fail, causing the retry mechanism to begin requerying with the same syntactically invalid query immediately, in an infinite loop. This causes a massive increase in log size which can in some cases cause a denial of service due to disk exhaustion. Opencast 13.10 and Opencast 14.3 contain patches which address the base issue, with Opencast 16.7 containing changes which harmonize the search behaviour between the admin UI and external API. Users are strongly recommended to upgrade as soon as possible if running versions prior to 13.10 or 14.3. While the relevant endpoints require (by default) `ROLE_ADMIN` or `ROLE_API_SERIES_VIEW`, the problem queries are otherwise innocuous. This issue could be easily triggered by normal administrative work on an affected Opencast system. Those who run a version newer than 13.10 and 14.3 and see different results when searching in their admin UI vs your external API or LMS, may resolve the issue by upgrading to 16.7. No known workarounds for the vulnerability are available.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

11.4 ≤ v < 13.1014.0 ≤ v < 14.315.0 ≤ v < 16.7
Affected range stops below 13.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.7, so it looks safe — our inference, not a vendor statement
v < 13.10v < 14.3v < 16.7
Affected range stops below 13.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card