CVE-2024-5131

Improper Access Control in lunary-ai/lunary

MEDIUM
6.5
CVSS Score
Published: June 6, 2024 at 06:31 PM UTC
Updated: June 17, 2026 at 08:15 AM UTC
2 products affected across 2 vendorsLunaryLunary

Using lunary-ai/lunary by lunary-ai?

Get instant alerts when new vulnerabilities affect lunary-ai/lunary - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

An Improper Access Control vulnerability exists in the lunary-ai/lunary repository, affecting versions up to and including 1.2.2. The vulnerability allows unauthorized users to view any prompts in any projects by supplying a specific prompt ID to an endpoint that does not adequately verify the ownership of the prompt ID. This issue was fixed in version 1.2.25.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.2.25
Affected range stops below 1.2.25, so it looks safe — our inference, not a vendor statement
v ≤ 1.2.2v < 1.2.25
Affected range stops below 1.2.25, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-639

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card