CVE-2024-47889

Action Mailer has possible ReDoS vulnerability in block_format

MEDIUM
6.6
CVSS Score
Published: October 16, 2024 at 08:55 PM UTC
Updated: June 17, 2026 at 07:57 AM UTC
2 products affected across 2 vendorsRailsRails

Using rails by rails?

Get instant alerts when new vulnerabilities affect rails - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.6
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

Action Mailer is a framework for designing email service layers. Starting in version 3.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the block_format helper in Action Mailer. Carefully crafted text can cause the block_format helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling the `block_format` helper or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 requires Ruby 3.2 or greater so is unaffected.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.1.7.9v < 7.0.8.5v < 7.1.4.1v < 7.2.1.1
Affected range stops below 6.1.7.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.8.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.4.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.2.1.1, so it looks safe — our inference, not a vendor statement
3.0.0 ≤ v < 6.1.7.97.0.0 ≤ v < 7.0.8.57.1.0 ≤ v < 7.1.4.17.2.0 ≤ v < 7.2.1.13.0.07.0.07.1.07.2.0
Affected range stops below 6.1.7.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.8.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.4.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.2.1.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.6MEDIUMGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-1333

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card