CVE-2024-47616

Pomerium's service account access token may grant unintended access to databroker API

MEDIUM
6.8
CVSS Score
Published: October 2, 2024 at 09:10 PM UTC
Updated: June 17, 2026 at 07:57 AM UTC
1 product affected across 1 vendorPomerium

Using pomerium by pomerium?

Get instant alerts when new vulnerabilities affect pomerium - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.8
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Pomerium is an identity and context-aware access proxy. The Pomerium databroker service is responsible for managing all persistent Pomerium application state. Requests to the databroker service API are authorized by the presence of a JSON Web Token (JWT) signed by a key known by all Pomerium services in the same deployment. However, incomplete validation of this JWT meant that some service account access tokens would incorrectly be treated as valid for the purpose of databroker API authorization. Improper access to the databroker API could allow exfiltration of user info, spoofing of user sessions, or tampering with Pomerium routes, policies, and other settings. A Pomerium deployment is susceptible to this issue if all of the following conditions are met, you have issued a service account access token using Pomerium Zero or Pomerium Enterprise, the access token has an explicit expiration date in the future, and the core Pomerium databroker gRPC API is not otherwise secured by network access controls. This vulnerability is fixed in 0.27.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.27.1
Affected range stops below 0.27.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.8MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card