CVE-2024-47524

LibreNMS has Stored Cross-site Scripting vulnerability in "Device Group" Name

MEDIUM
4.8
CVSS Score
Published: October 1, 2024 at 08:30 PM UTC
Updated: June 17, 2026 at 07:57 AM UTC
1 product affected across 1 vendorLibrenms

Using librenms by librenms?

Get instant alerts when new vulnerabilities affect librenms - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. User with Admin role can create a Device Groups, the application did not properly sanitize the user input in the Device Groups name, when user see the detail of the Device Group, if java script code is inside the name of the Device Groups, its will be trigger. This vulnerability is fixed in 24.9.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 24.9.024.9.0
Affected range stops below 24.9.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card