CVE-2024-47249

Apache NimBLE: Lack of input sanitization leading to out-of-bound reads in multiple advertisement handler

MEDIUM
5
CVSS Score
Published: November 26, 2024 at 11:16 AM UTC
Updated: June 17, 2026 at 07:56 AM UTC
1 product affected across 1 vendorNimble

Using Apache NimBLE by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache NimBLE - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 1.7.0
Affected range stops below 1.8.0, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5MEDIUMCISA-ADP
Attack Vector
ADJACENT_NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-129

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card