CVE-2024-45312

Arbitrary language parameter can passed to `aspell` executable via spelling requests in overleaf

MEDIUM
5.3
CVSS Score
Published: September 2, 2024 at 04:50 PM UTC
Updated: June 17, 2026 at 07:54 AM UTC
1 product affected across 1 vendorOverleaf

Using overleaf by overleaf?

Get instant alerts when new vulnerabilities affect overleaf - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server. This causes `aspell` to attempt to load a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7. Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature. However, upgrading is advised.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.2.7v < 5.0.74.0.0 ≤ v < 4.2.75.0.0 ≤ v < 5.0.74.0.05.0.0
Affected range stops below 4.2.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-22CWE-641CWE-74

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card