CVE-2024-44308

HIGH
8.8
CVSS Score
Published: November 19, 2024 at 11:43 PM UTC
Updated: June 17, 2026 at 07:52 AM UTC
6 products affected across 2 vendorsmacOSDebian LinuxiPhone OS

Using Safari by Apple?

Get instant alerts when new vulnerabilities affect Safari - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploitation
CISA KEV
Exploit prediction
EPSS 10%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score10.2%

EPSS (Exploit Prediction Scoring System) estimates a 10.2% chance this CVE is exploited in the wild within the next 30 days — higher than 96% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Apple iOS, macOS, and other Apple products contain an unspecified vulnerability when processing maliciously crafted web content that may lead to arbitrary code execution.

Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Nov 21, 2024
Remediation Due
Dec 12, 2024
683 days overdue

Description

The issue was addressed with improved checks. This issue is fixed in Safari 18.1.1, iOS 17.7.2 and iPadOS 17.7.2, macOS Sequoia 15.1.1, iOS 18.1.1 and iPadOS 18.1.1, visionOS 2.1.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited on Intel-based Mac systems.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 17.7v < 17.7.2v < 18.1.118.0 ≤ v < 18.118.0 ≤ v < 18.1.118.0
Affected range stops below 17.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.7.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.1.1, so it looks safe — our inference, not a vendor statement
v < 17.7v < 17.7.218.0 ≤ v < 18.118.0 ≤ v < 18.1.118.0
Affected range stops below 17.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.7.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.1.1, so it looks safe — our inference, not a vendor statement
v < 15.115.0 ≤ v < 15.1.1
Affected range stops below 15.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1.1, so it looks safe — our inference, not a vendor statement
v < 18.1v < 18.1.1
Affected range stops below 18.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.1.1, so it looks safe — our inference, not a vendor statement
v < 2.1v < 2.1.1
Affected range stops below 2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (8)

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card