CVE-2024-42491

A malformed Contact or Record-Route URI in an incoming SIP request can cause Asterisk to crash when res_resolver_unbound is used

MEDIUM
5.7
CVSS Score
Published: September 5, 2024 at 05:17 PM UTC
Updated: June 17, 2026 at 07:49 AM UTC
3 products affected across 2 vendorsAsteriskCertified AsteriskAsterisk

Using asterisk by asterisk?

Get instant alerts when new vulnerabilities affect asterisk - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.7
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Asterisk is an open-source private branch exchange (PBX). Prior to versions 18.24.3, 20.9.3, and 21.4.3 of Asterisk and versions 18.9-cert12 and 20.7-cert2 of certified-asterisk, if Asterisk attempts to send a SIP request to a URI whose host portion starts with `.1` or `[.1]`, and res_resolver_unbound is loaded, Asterisk will crash with a SEGV. To receive a patch, users should upgrade to one of the following versions: 18.24.3, 20.9.3, 21.4.3, certified-18.9-cert12, certified-20.7-cert2. Two workarounds are available. Disable res_resolver_unbound by setting `noload = res_resolver_unbound.so` in modules.conf, or set `rewrite_contact = yes` on all PJSIP endpoints. NOTE: This may not be appropriate for all Asterisk configurations.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 18.24.320.0.0 ≤ v < 20.9.321.0.0 ≤ v ≤ 21.4.3
Affected range stops below 18.24.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.9.3, so it looks safe — our inference, not a vendor statement
v < 18.24.3v < 18.9-cert12v < 20.7-cert2v < 20.9.3v < 21.4.3
Affected range stops below 18.24.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.9-cert12, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.7-cert2, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.9.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4.3, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.7MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-252CWE-476

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card