CVE-2024-4181

Command Injection in run-llama/llama_index

HIGH
8.8
CVSS Score
Published: May 16, 2024 at 09:03 AM UTC
Updated: June 17, 2026 at 08:01 AM UTC
2 products affected across 2 vendorsLlamaindexLlamaindex

Using run-llama/llama_index by run-llama?

Get instant alerts when new vulnerabilities affect run-llama/llama_index - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%
SSVC
No known exploit

Description

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.9.47 ≤ v < 0.10.13
v < 0.10.130.9.47
Affected range stops below 0.10.13, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGH@huntr_ai
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card