CVE-2024-39877

Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler

HIGH
8.8
CVSS Score
Published: July 17, 2024 at 07:54 AM UTC
Updated: June 17, 2026 at 07:42 AM UTC
1 product affected across 1 vendorAirflow

Using Apache Airflow by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Airflow - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%
SSVC
PoC

Description

Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.4.0 ≤ v < 2.9.32.4.0
Affected range stops below 2.9.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-94CWE-277

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card