CVE-2024-39614

HIGH
7.5
CVSS Score
Published: July 10, 2024 at 12:00 AM UTC
Updated: June 17, 2026 at 07:42 AM UTC
1 product affected across 1 vendorDjango

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 29%
SSVC
No known exploit

Description

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containing specific characters.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.2 ≤ v < 4.2.145.0 ≤ v < 5.0.74.25.0
Affected range stops below 4.2.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-130

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card