CVE-2024-39308

RailsAdmin Cross-site Scripting vulnerability in the list view

MEDIUM
5.4
CVSS Score
Published: July 8, 2024 at 02:33 PM UTC
Updated: June 17, 2026 at 07:41 AM UTC
2 products affected across 2 vendorsRails AdminAdmin Project Rails Admin

Using rails_admin by railsadminteam?

Get instant alerts when new vulnerabilities affect rails_admin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

RailsAdmin is a Rails engine that provides an interface for managing data. RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. Upgrade to 3.1.3 or 2.2.2 (to be released).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.3.03.0.0 ≤ v < 3.1.3
Affected range stops below 2.3.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.3, so it looks safe — our inference, not a vendor statement
v < 2.3.0v < 3.1.3
Affected range stops below 2.3.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.3, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card