CVE-2024-37899

Disabling a user account changes its author, allowing RCE from user account in XWiki

HIGH
8
CVSS Score
Published: June 20, 2024 at 10:13 PM UTC
Updated: June 17, 2026 at 07:39 AM UTC
1 product affected across 1 vendorXwiki

Using xwiki-platform by xwiki?

Get instant alerts when new vulnerabilities affect xwiki-platform - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8
Exploit prediction
EPSS 0.7%
SSVC
PoC

Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an admin disables a user account, the user's profile is executed with the admin's rights. This allows a user to place malicious code in the user profile before getting an admin to disable the user account. To reproduce, as a user without script nor programming rights, edit the about section of your user profile and add `{{groovy}}services.logging.getLogger("attacker").error("Hello from Groovy!"){{/groovy}}`. As an admin, go to the user profile and click the "Disable this account" button. Then, reload the page. If the logs show `attacker - Hello from Groovy!` then the instance is vulnerable. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0. Users are advised to upgrade. There are no known workarounds for this vulnerability. ### Workarounds We're not aware of any workaround except upgrading. ### References * https://jira.xwiki.org/browse/XWIKI-21611 * https://github.com/xwiki/xwiki-platform/commit/f89c8f47fad6e5cc7e68c69a7e0acde07f5eed5a

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 13.5v < 14.10.21v < 15.10.6v < 15.5.5v < 16.0.013.10.3 ≤ v ≤ 14.10.2113.10.3 ≤ v < 14.10.2113.4.7 ≤ v ≤ 13.515.0 ≤ v < 15.5.515.0-rc-1 ≤ v < 15.5.515.6 ≤ v < 15.10.615.6-rc-1, ≤ v < 15.10.616.0.0-rc-1, ≤ v < 16.0.013.10.313.4.713.5 rc115.0-rc-115.6-rc-116.0.0 rc116.0.0-rc-1
Affected range stops below 14.10.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.10.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.5.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.0.0, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card