CVE-2024-35164

Apache Guacamole: Improper input validation of console codes

HIGH
7.5
CVSS Score
Published: July 2, 2025 at 11:23 AM UTC
Updated: June 17, 2026 at 07:34 AM UTC
1 product affected across 1 vendorGuacamole

Using Apache Guacamole by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Guacamole - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.8.0 ≤ v ≤ 1.5.50.8.0 ≤ v < 1.6.00.8.0
Affected range stops below 1.6.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-129NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card