CVE-2024-3511

Incorrect Authorization in Multiple WSO2 Products Allows Unauthorized Access to Registry Versioned Files

MEDIUM
4.3
CVSS Score
Published: June 23, 2025 at 08:47 AM UTC
Updated: June 17, 2026 at 07:44 AM UTC
7 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Enterprise Integrator by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Enterprise Integrator - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

An incorrect authorization vulnerability exists in multiple WSO2 products that allows unauthorized access to versioned files stored in the registry. Due to flawed authorization logic, a malicious actor with access to the management console can exploit a specific bypass method to retrieve versioned files without proper authorization. Successful exploitation of this vulnerability could lead to unauthorized disclosure of configuration or resource files that may be stored as registry versions, potentially aiding further attacks or system reconnaissance.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.1.0 ≤ v < 3.1.0.2733.2.0 ≤ v < 3.2.0.3613.2.1 ≤ v < 3.2.1.134.0.0 ≤ v < 4.0.0.3064.1.0 ≤ v < 4.1.0.1634.2.0 ≤ v < 4.2.0.984.3.0 ≤ v < 4.3.0.173.1.03.2.03.2.14.0.04.1.04.2.04.3.0
Affected range stops below 3.1.0.273, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.361, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.306, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.163, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.98, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.17, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
6.6.0 ≤ v < 6.6.0.2056.6.0
Affected range stops below 6.6.0.205, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
5.10.0 ≤ v < 5.10.0.2925.11.0 ≤ v < 5.11.0.3336.0.0 ≤ v < 6.0.0.1806.1.0 ≤ v < 6.1.0.1417.0.0 ≤ v < 7.0.0.85.10.05.11.06.0.06.1.07.0.0
Affected range stops below 5.10.0.292, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.333, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.180, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.141, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.8, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.2895.10.0
Affected range stops below 5.10.0.289, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.3202.0.0
Affected range stops below 2.0.0.320, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.3412.0.0
Affected range stops below 2.0.0.341, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
4.10.9 ≤ v < 4.10.9.84.5.0 ≤ v < 4.5.0.54.5.3 ≤ v < 4.5.3.354.6.0 ≤ v < 4.6.0.1404.6.1 ≤ v < 4.6.1.1074.6.2 ≤ v < 4.6.2.3234.6.3 ≤ v < 4.6.3.184.6.4 ≤ v < 4.6.4.34.7.1 ≤ v < 4.7.1.474.8.1 ≤ v < 4.8.1.194.9.0 ≤ v < 4.9.0.524.9.26 ≤ v < 4.9.26.104.10.94.5.04.5.34.6.04.6.14.6.24.6.34.6.44.7.14.8.14.9.04.9.26
Vendor states this is fixed in 4.10.13 (unaffected)
Affected range stops below 4.10.9.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.3.35, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.140, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.1.107, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.2.323, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.3.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.4.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.1.47, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.1.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.0.52, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.26.10, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMWSO2
Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card