CVE-2024-3509

Stored Cross-Site Scripting (XSS) in Management Console of Multiple WSO2 Products via Rich Text Editor

MEDIUM
4.3
CVSS Score
Published: June 2, 2025 at 04:44 PM UTC
Updated: June 17, 2026 at 07:44 AM UTC
7 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Enterprise Integrator by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Enterprise Integrator - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

A stored cross-site scripting (XSS) vulnerability exists in the Management Console of multiple WSO2 products due to insufficient input validation in the Rich Text Editor within the registry section. To exploit this vulnerability, a malicious actor must have a valid user account with administrative access to the Management Console. If successful, the actor could inject persistent JavaScript payloads, enabling the theft of user data or execution of unauthorized actions on behalf of other users. While this issue enables persistent client-side script execution, session-related cookies remain protected with the httpOnly flag, preventing session hijacking.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.1.0 ≤ v < 3.1.0.2753.2.0 ≤ v < 3.2.0.3923.2.1 ≤ v < 3.2.1.194.0.0 ≤ v < 4.0.0.3084.1.0 ≤ v < 4.1.0.1714.2.0 ≤ v < 4.2.0.1074.3.0 ≤ v < 4.3.0.213.1.03.2.03.2.14.0.04.1.04.2.04.3.0
Affected range stops below 3.1.0.275, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.392, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.308, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.171, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.107, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.21, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
6.6.0 ≤ v < 6.6.0.2026.6.0
Affected range stops below 6.6.0.202, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
5.10.0 ≤ v < 5.10.0.2965.11.0 ≤ v < 5.11.0.3336.0.0 ≤ v < 6.0.0.1816.1.0 ≤ v < 6.1.0.1427.0.0 ≤ v < 7.0.0.95.10.05.11.06.0.06.1.07.0.0
Affected range stops below 5.10.0.296, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.333, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.181, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.142, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.9, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.2925.10.0
Affected range stops below 5.10.0.292, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
4.7.24 ≤ v < 4.7.24.64.7.32 ≤ v < 4.7.32.104.7.33 ≤ v < 4.7.33.84.7.35 ≤ v < 4.7.35.84.7.39 ≤ v < 4.7.39.64.7.51 ≤ v < 4.7.51.24.8.12 ≤ v < 4.8.12.24.8.13 ≤ v < 4.8.13.44.8.24 ≤ v < 4.8.24.14.8.3 ≤ v < 4.8.3.74.8.32 ≤ v < 4.8.32.24.8.9 ≤ v < 4.8.9.34.7.244.7.324.7.334.7.354.7.394.7.514.8.124.8.134.8.244.8.34.8.324.8.9
Affected range stops below 4.7.24.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.32.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.33.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.35.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.39.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.51.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.12.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.13.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.24.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.3.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.32.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.8.35 (unaffected)
Affected range stops below 4.8.9.3, so it looks safe — our inference, not a vendor statement
2.0.0 ≤ v < 2.0.0.3252.0.0
Affected range stops below 2.0.0.325, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.3452.0.0
Affected range stops below 2.0.0.345, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMWSO2
Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card