CVE-2024-3504

Improper Access Control in lunary-ai/lunary

MEDIUM
6.5
CVSS Score
Published: June 6, 2024 at 05:53 PM UTC
Updated: June 17, 2026 at 07:44 AM UTC
2 products affected across 2 vendorsLunaryLunary

Using lunary-ai/lunary by lunary-ai?

Get instant alerts when new vulnerabilities affect lunary-ai/lunary - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

An improper access control vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, where an admin can update any organization user to the organization owner. This vulnerability allows the elevated user to delete projects within the organization. The issue is resolved in version 1.2.7.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.2.7
Affected range stops below 1.2.7, so it looks safe — our inference, not a vendor statement
v ≤ 1.2.7v < 1.2.7
Affected range stops below 1.2.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-284NVD-CWE-noinfoCWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card