CVE-2024-3386

PAN-OS: Predefined Decryption Exclusions Does Not Work as Intended

MEDIUM
5.3
CVSS Score
Published: April 10, 2024 at 05:06 PM UTC
Updated: June 17, 2026 at 07:44 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

An incorrect string comparison vulnerability in Palo Alto Networks PAN-OS software prevents Predefined Decryption Exclusions from functioning as intended. This can cause traffic destined for domains that are not specified in Predefined Decryption Exclusions to be unintentionally excluded from decryption.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0.0 ≤ v < 10.0.1310.1.0 ≤ v ≤ 10.1.810.1.0 ≤ v < 10.1.1010.1.0 ≤ v < 10.1.9-h310.2.0 ≤ v < 10.2.410.2.0 ≤ v < 10.2.4-h210.2.0 ≤ v < 10.2.511.0.0 ≤ v < 11.0.111.0.0 ≤ v < 11.0.1-h211.0.0 ≤ v < 11.0.29.0.0 ≤ v < 9.0.169.0.0 ≤ v < 9.0.17-h29.1.0 ≤ v < 9.1.1710.0.010.1.010.1.910.1.9 h110.2.010.2.411.0.011.0.19.0.09.0.179.0.17 h19.1.0
Affected range stops below 10.0.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.1.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.1.9-h3, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.2.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.2.4-h2, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.2.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.1-h2, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 11.1.0 (unaffected)
Affected range stops below 9.0.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.17-h2, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.17, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMpalo_alto
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-436

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card