CVE-2024-33522

Privilege escalation in Calico CNI install binary

MEDIUM
6.7
CVSS Score
Published: April 29, 2024 at 10:19 PM UTC
Updated: June 17, 2026 at 07:31 AM UTC
3 products affected across 2 vendorsCalicoCalico EnterpriseCalico Cloud

Using Calico by Tigera?

Get instant alerts when new vulnerabilities affect Calico - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.7
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

In vulnerable versions of Calico (v3.27.2 and below), Calico Enterprise (v3.19.0-1, v3.18.1, v3.17.3 and below), and Calico Cloud (v19.2.0 and below), an attacker who has local access to the Kubernetes node, can escalate their privileges by exploiting a vulnerability in the Calico CNI install binary. The issue arises from an incorrect SUID (Set User ID) bit configuration in the binary, combined with the ability to control the input binary, allowing an attacker to execute an arbitrary binary with elevated privileges.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < v19.3.0v < v3.26.5v3.27.0 ≤ v < v3.27.33.27.0
Affected range stops below v19.3.0, so it looks safe — our inference, not a vendor statement
Affected range stops below v3.26.5, so it looks safe — our inference, not a vendor statement
Affected range stops below v3.27.3, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in v3.28.0 (unaffected)
v < v19.3.0
Affected range stops below v19.3.0, so it looks safe — our inference, not a vendor statement
v < v3.17.4v3.18.0 ≤ v < v3.18.2v3.19.0-1.0 ≤ v < v3.19.0-2.03.18.03.19.0-1.0
Affected range stops below v3.17.4, so it looks safe — our inference, not a vendor statement
Affected range stops below v3.18.2, so it looks safe — our inference, not a vendor statement
Affected range stops below v3.19.0-2.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.7MEDIUMTigera
Attack Vector
LOCAL
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card