CVE-2024-32469

Decidim has cross-site scripting (XSS) in the pagination

HIGH
7.1
CVSS Score
Published: July 10, 2024 at 07:10 PM UTC
Updated: June 17, 2026 at 07:29 AM UTC
1 product affected across 1 vendorDecidim

Using decidim by decidim?

Get instant alerts when new vulnerabilities affect decidim - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter `per_page`. This vulnerability is fixed in 0.27.6 and 0.28.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.27.6v < 0.28.1
Affected range stops below 0.27.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.28.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.1HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card