CVE-2024-32463

phlex makes Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags

HIGH
7.1
CVSS Score
Published: April 17, 2024 at 03:29 PM UTC
Updated: June 17, 2026 at 07:29 AM UTC
2 products affected across 2 vendorsFileUtilsPhlex

Using phlex by phlex-ruby?

Get instant alerts when new vulnerabilities affect phlex - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

phlex is an open source framework for building object-oriented views in Ruby. There is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. The filter to detect and prevent the use of the `javascript:` URL scheme in the `href` attribute of an `<a>` tag could be bypassed with tab `\t` or newline `\n` characters between the characters of the protocol, e.g. `java\tscript:`. This vulnerability is fixed in 1.10.1, 1.9.2, 1.8.3, 1.7.2, 1.6.3, 1.5.3, and 1.4.2. Configuring a Content Security Policy that does not allow `unsafe-inline` would effectively prevent this vulnerability from being exploited.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.10.1v < 1.4.2v < 1.5.3v < 1.6.3v < 1.7.2v < 1.8.3v < 1.9.2
Affected range stops below 1.10.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.5.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.6.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.7.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.8.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.1HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card