CVE-2024-32462

Flatpak vulnerable to a sandbox escape via RequestBackground portal due to bad argument parsing

HIGH
8.4
CVSS Score
Published: April 18, 2024 at 06:11 PM UTC
Updated: June 17, 2026 at 07:29 AM UTC
2 products affected across 2 vendorsFedoraFlatpak

Using flatpak by flatpak?

Get instant alerts when new vulnerabilities affect flatpak - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.4
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. in versions before 1.10.9, 1.12.9, 1.14.6, and 1.15.8, a malicious or compromised Flatpak app could execute arbitrary code outside its sandbox. Normally, the `--command` argument of `flatpak run` expects to be given a command to run in the specified Flatpak app, optionally along with some arguments. However it is possible to instead pass `bwrap` arguments to `--command=`, such as `--bind`. It's possible to pass an arbitrary `commandline` to the portal interface `org.freedesktop.portal.Background.RequestBackground` from within a Flatpak app. When this is converted into a `--command` and arguments, it achieves the same effect of passing arguments directly to `bwrap`, and thus can be used for a sandbox escape. The solution is to pass the `--` argument to `bwrap`, which makes it stop processing options. This has been supported since bubblewrap 0.3.0. All supported versions of Flatpak require at least that version of bubblewrap. xdg-desktop-portal version 1.18.4 will mitigate this vulnerability by only allowing Flatpak apps to create .desktop files for commands that do not start with --. The vulnerability is patched in 1.15.8, 1.10.9, 1.12.9, and 1.14.6.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.10.9v < 1.12.9v < 1.14.6v < 1.15.81.12.0 ≤ v < 1.12.91.14.0 ≤ v < 1.14.61.15.0 ≤ v < 1.15.81.15.0
Affected range stops below 1.10.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.12.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.14.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.15.8, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.4HIGHGitHub_M
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-88

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card