CVE-2024-3238

WordPress Menu Plugin — Superfly Responsive Menu <= 5.0.29 - Cross-Site Request Forgery to Arbitrary File Deletion

HIGH
8.8
CVSS Score
Published: August 2, 2024 at 06:41 AM UTC
Updated: June 17, 2026 at 07:43 AM UTC
1 product affected across 1 vendorSuperfly Menu

Using WordPress Menu Plugin — Superfly Responsive Menu by looks_awesome?

Get instant alerts when new vulnerabilities affect WordPress Menu Plugin — Superfly Responsive Menu - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

The WordPress Menu Plugin — Superfly Responsive Menu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.0.29. This is due to missing or incorrect nonce validation on the ajax_handle_delete_icons() function. This makes it possible for unauthenticated attackers to delete arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please not the CSRF was patched in 5.0.28, however, adequate directory traversal protection wasn't introduced until 5.0.30.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 5.0.29

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHWordfence
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card