CVE-2024-32024

Kohya_ss vulenrable to path injection in `common_gui.py` `add_pre_postfix` function (`GHSL-2024-023`)

MEDIUM
6.5
CVSS Score
Published: April 16, 2024 at 02:42 PM UTC
Updated: June 17, 2026 at 07:29 AM UTC
1 product affected across 1 vendorKohya Ss

Using kohya_ss by bmaltais?

Get instant alerts when new vulnerabilities affect kohya_ss - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.7%
SSVC
PoC

Description

Kohya_ss is a GUI for Kohya's Stable Diffusion trainers. Kohya_ss is vulnerable to a path injection in the `common_gui.py` `add_pre_postfix` function. This vulnerability is fixed in 23.1.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 23.1.522.6.1 ≤ v < 23.1.522.6.1 ≤ v < 24.0.122.6.1
Affected range stops below 23.1.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.0.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card