CVE-2024-32020

Cloning local Git repository by untrusted user allows the untrusted user to modify objects in the cloned repository at will

LOW
3.3
CVSS Score
Published: May 14, 2024 at 06:54 PM UTC
Updated: June 17, 2026 at 07:29 AM UTC
3 products affected across 3 vendorsFedoraGitGit

Using git by git?

Get instant alerts when new vulnerabilities affect git - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.3
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, local clones may end up hardlinking files into the target repository's object database when source and target repository reside on the same disk. If the source repository is owned by a different user, then those hardlinked files may be rewritten at any point in time by the untrusted user. Cloning local repositories will cause Git to either copy or hardlink files of the source repository into the target repository. This significantly speeds up such local clones compared to doing a "proper" clone and saves both disk space and compute time. When cloning a repository located on the same disk that is owned by a different user than the current user we also end up creating such hardlinks. These files will continue to be owned and controlled by the potentially-untrusted user and can be rewritten by them at will in the future. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Git· Gitrubygems
95%
v < 2.39.4v < 2.40.2v < 2.42.2v < 2.43.42.40.0 ≤ v < 2.40.22.42.0 ≤ v < 2.42.22.43 ≤ v < 2.43.42.40.02.41.02.42.02.432.44.02.45.0= 2.41.0= 2.44.0= 2.45.0
Affected range stops below 2.39.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.40.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.42.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.43.4, so it looks safe — our inference, not a vendor statement
v < 2.39.42.40.0 ≤ v < 2.40.22.42.0 ≤ v < 2.42.22.43.0 ≤ v < 2.43.42.41.02.44.02.45.0

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-281

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card