CVE-2024-32004

Git vulnerable to Remote Code Execution while cloning special-crafted local repositories

HIGH
7.8
CVSS Score
Published: May 14, 2024 at 06:46 PM UTC
Updated: June 17, 2026 at 07:29 AM UTC
4 products affected across 4 vendorsDebian LinuxFedoraGit

Using git by git?

Get instant alerts when new vulnerabilities affect git - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Git· Gitrubygems
95%
v < 2.39.4v < 2.40.2v < 2.42.2v < 2.43.42.40.0 ≤ v < 2.40.22.42.0 ≤ v < 2.42.22.43.0 ≤ v < 2.43.42.40.02.41.02.42.02.43.02.44.02.45.0= 2.41.0= 2.44.0= 2.45.0
Affected range stops below 2.39.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.40.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.42.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.43.4, so it looks safe — our inference, not a vendor statement
v < 2.39.42.40.0 ≤ v < 2.40.22.42.0 ≤ v < 2.42.22.43.0 ≤ v < 2.43.42.41.02.44.02.45.0

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-114

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card