CVE-2024-3190

Unlimited Elements For Elementor (Free Widgets, Addons, Templates) <= 1.5.107 - Authenticated (Contributor+) Stored Cross-Site Scripting via Text Field

MEDIUM
4.6
CVSS Score
Published: May 30, 2024 at 03:34 AM UTC
Updated: June 17, 2026 at 07:43 AM UTC
2 products affected across 2 vendorsUnlimited Elements For ElementorUnlimited Elements For Elementor

Using Unlimited Elements For Elementor (Free Widgets, Addons, Templates) by unitecms?

Get instant alerts when new vulnerabilities affect Unlimited Elements For Elementor (Free Widgets, Addons, Templates) - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.6
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's text field widget in all versions up to, and including, 1.5.107 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Please note that this vulnerability is different in that the issue stems from an external template. It appears that older version may also be patched due to this, however, we are choosing 1.5.108 as the patched version since that is the most recent version containing as known patch.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.5.108
Affected range stops below 1.5.108, so it looks safe — our inference, not a vendor statement
v ≤ 1.5.107

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card