CVE-2024-30246

Tuleap deleting or moving an artifact can delete values from unrelated artifacts

HIGH
7.1
CVSS Score
Published: March 29, 2024 at 03:50 PM UTC
Updated: June 17, 2026 at 07:26 AM UTC
1 product affected across 1 vendorTuleap

Using tuleap by Enalean?

Get instant alerts when new vulnerabilities affect tuleap - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Tuleap is an Open Source Suite to improve management of software developments and collaboration. A malicious user could exploit this issue on purpose to delete information on the instance or possibly gain access to restricted artifacts. It is however not possible to control exactly which information is deleted. Information from theDate, File, Float, Int, List, OpenList, Text, and Permissions on artifact (this one can lead to the disclosure of restricted information) fields can be impacted. This vulnerability is fixed in Tuleap Community Edition version 15.7.99.6 and Tuleap Enterprise Edition 15.7-2, 15.6-5, 15.5-6, 15.4-8, 15.3-6, 15.2-5, 15.1-9, 15.0-9, and 14.12-6.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.7.99.614.11.99.34 ≤ v < 15.7.99.614.12-1 ≤ v < 14.12-615.0-1 ≤ v < 15.0-915.1-1 ≤ v < 15.1-915.2-1 ≤ v < 15.2-515.3-1 ≤ v < 15.3-615.4-1 ≤ v < 15.4-815.5-1 ≤ v < 15.5-615.6-1 ≤ v < 15.6-515.7-1
Affected range stops below 14.12-6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.0-9, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1-9, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.2-5, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.3-6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.4-8, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.5-6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.6-5, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.7.99.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-440CWE-670NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card