CVE-2024-29904

CodeIgniter4 Language class DoS Vulnerability

HIGH
7.5
CVSS Score
Published: March 29, 2024 at 03:32 PM UTC
Updated: June 17, 2026 at 07:23 AM UTC
2 products affected across 2 vendorsCodeigniterCodeigniter

Using CodeIgniter4 by codeigniter4?

Get instant alerts when new vulnerabilities affect CodeIgniter4 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.8%
SSVC
PoC

Description

CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.4.74.0 ≤ v < 4.4.74.0
Affected range stops below 4.4.7, so it looks safe — our inference, not a vendor statement
v < 4.4.7
Affected range stops below 4.4.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-835CWE-674

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card