CVE-2024-29834

Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints

MEDIUM
6.4
CVSS Score
Published: April 2, 2024 at 07:24 PM UTC
Updated: June 17, 2026 at 07:23 AM UTC
1 product affected across 1 vendorPulsar

Using Apache Pulsar by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Pulsar - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.4
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to 2.11.4, from 3.0.0 to 3.0.3, from 3.1.0 to 3.1.3, and from 3.2.0 to 3.2.1. 3.0 Apache Pulsar users should upgrade to at least 3.0.4. 3.1 and 3.2 Apache Pulsar users should upgrade to at least 3.2.2. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.11.0 ≤ v ≤ 2.11.42.7.1 ≤ v ≤ 2.10.63.0.0 ≤ v < 3.0.43.1.0 ≤ v ≤ 3.1.33.2.0 ≤ v < 3.2.22.11.02.7.13.0.03.1.03.2.0
Affected range stops below 3.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.4MEDIUMapache
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card