CVE-2024-29217

Apache Answer: XSS vulnerability when changing personal website

MEDIUM
4.6
CVSS Score
Published: April 21, 2024 at 04:04 PM UTC
Updated: June 17, 2026 at 07:22 AM UTC
1 product affected across 1 vendorAnswer

Using Apache Answer by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Answer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.6
Exploit prediction
EPSS 1.0%
SSVC
No known exploit

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: before 1.3.0. XSS attack when user changes personal website. A logged-in user, when modifying their personal website, can input malicious code in the website to create such an attack. Users are recommended to upgrade to version [1.3.0], which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.3.0
Affected range stops below 1.3.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.6MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card