CVE-2024-29210

LOW
2.8
CVSS Score
Published: May 7, 2024 at 04:53 PM UTC
Updated: June 17, 2026 at 07:22 AM UTC
3 products affected across 1 vendorPhish Alert ButtonpasswordIQ_clientSecond Chance Client

Using Phish Alert Button (PAB) for Outlook by KnowBe4?

Get instant alerts when new vulnerabilities affect Phish Alert Button (PAB) for Outlook - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW2.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

A local privilege escalation (LPE) vulnerability has been identified in Phish Alert Button for Outlook (PAB), specifically within its configuration management functionalities. This vulnerability allows a regular user to modify the application's configuration file to redirect update checks to an arbitrary server, which can then be exploited in conjunction with CVE-2024-29209 to execute arbitrary code with elevated privileges. The issue stems from improper permission settings on the application's configuration file, which is stored in a common directory accessible to all users. This file includes critical parameters, such as the update server URL. By default, the application does not enforce adequate access controls on this file, allowing non-privileged users to modify it without administrative consent. An attacker with regular user access can alter the update server URL specified in the configuration file to point to a malicious server. When the application performs its next update check, it will contact the attacker-controlled server. If the system is also vulnerable to CVE-2024-29209, the attacker can deliver a malicious update package that, when executed, grants them elevated privileges. Impact: This vulnerability can lead to a regular user executing code with administrative privileges. This can result in unauthorized access to sensitive data, installation of additional malware, and a full takeover of the affected system. Affected Products: Phish Alert Button (PAB) for Outlook versions 1.10.0-1.10.11 Second Chance Client versions 2.0.0-2.0.9 PIQ Client versions 1.0.0-1.0.15 Remediation: KnowBe4 has released a patch that corrects the permission settings on the configuration file to prevent unauthorized modifications. Automated updates will be pushed to address this issue. Users of affected versions should verify the latest version is applied and, if not, apply the latest updates provided by KnowBe4. Workarounds: Manually set the correct permissions on the configuration file to restrict write access to administrators only. Credits: This vulnerability was discovered by Ceri Coburn at Pen Test Partners, who reported it responsibly to the vendor.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.0.161.0.0 ≤ v < 1.0.161.0.0
Vendor states this is fixed in 1.0.0 (unaffected)
Affected range stops below 1.0.16, so it looks safe — our inference, not a vendor statement
v < 1.10.121.10.0 ≤ v < 1.10.121.10.0
Vendor states this is fixed in 1.10.0 (unaffected)
Affected range stops below 1.10.12, so it looks safe — our inference, not a vendor statement
v < 2.0.102.0.0 ≤ v < 2.0.102.0.0
Vendor states this is fixed in 2.0.0 (unaffected)
Affected range stops below 2.0.10, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

2.8LOWhackerone
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card