CVE-2024-28175

Cross-site scripting on application summary component in argo-cd

MEDIUM
5.4
CVSS Score
Published: March 13, 2024 at 08:48 PM UTC
Updated: June 17, 2026 at 07:21 AM UTC
1 product affected across 1 vendorArgo CD

Using argo-cd by argoproj?

Get instant alerts when new vulnerabilities affect argo-cd - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Due to the improper URL protocols filtering of links specified in the `link.argocd.argoproj.io` annotations in the application summary component, an attacker can achieve cross-site scripting with elevated permissions. All unpatched versions of Argo CD starting with v1.0.0 are vulnerable to a cross-site scripting (XSS) bug allowing a malicious user to inject a javascript: link in the UI. When clicked by a victim user, the script will execute with the victim's permissions (up to and including admin). This vulnerability allows an attacker to perform arbitrary actions on behalf of the victim via the API, such as creating, modifying, and deleting Kubernetes resources. A patch for this vulnerability has been released in Argo CD versions v2.10.3 v2.9.8, and v2.8.12. There are no completely-safe workarounds besides upgrading. The safest alternative, if upgrading is not possible, would be to create a Kubernetes admission controller to reject any resources with an annotation starting with link.argocd.argoproj.io or reject the resource if the value use an improper URL protocol. This validation will need to be applied in all clusters managed by ArgoCD.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.10.3v < 2.8.12v < 2.9.81.0.0 ≤ v < 2.8.122.10.0 ≤ v < 2.10.32.9.0 ≤ v < 2.9.81.0.02.10.02.9.0
Affected range stops below 2.10.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.8.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.9.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card