CVE-2024-27906

Apache Airflow: Dag Code and Import Error Permissions Ignored

MEDIUM
5.9
CVSS Score
Published: February 29, 2024 at 11:02 AM UTC
Updated: June 17, 2026 at 07:20 AM UTC
1 product affected across 1 vendorAirflow

Using Apache Airflow by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Airflow - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.8.2
Affected range stops below 2.8.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.9MEDIUMCISA-ADP
Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card