CVE-2024-25723

HIGH
8.8
CVSS Score
Published: February 27, 2024 at 12:00 AM UTC
Updated: June 17, 2026 at 07:16 AM UTC
2 products affected across 2 vendorsZenmlZenml

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 71%
SSVC
PoC

Description

ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.42.20.44.0 ≤ v < 0.44.40.45.0 ≤ v < 0.46.70.43.0
Affected range stops below 0.42.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.44.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.46.7, so it looks safe — our inference, not a vendor statement
v < 0.46.7
Affected range stops below 0.46.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
NVD-CWE-noinfoCWE-284

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card