CVE-2024-24812

Frappe Authenticated Reflected Cross site scripting (XSS) in portal pages

MEDIUM
5.4
CVSS Score
Published: February 7, 2024 at 03:03 PM UTC
Updated: June 17, 2026 at 07:14 AM UTC
1 product affected across 1 vendorFrappe

Using frappe by frappe?

Get instant alerts when new vulnerabilities affect frappe - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known workarounds are available.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 14.59.0v < 15.5.015.0.0 ≤ v < 15.5.0
Affected range stops below 14.59.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.5.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.4MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79CWE-80

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card