CVE-2024-24574

phpMyFAQ vulnerable to stored XSS on attachments filename

MEDIUM
6.1
CVSS Score
Published: February 5, 2024 at 08:57 PM UTC
Updated: June 17, 2026 at 07:14 AM UTC
2 products affected across 2 vendorsphpMyFAQphpMyFAQ

Using phpMyFAQ by thorsten?

Get instant alerts when new vulnerabilities affect phpMyFAQ - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.9%
SSVC
PoC

Description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.2.5
Affected range stops below 3.2.5, so it looks safe — our inference, not a vendor statement
v < 3.2.5
Affected range stops below 3.2.5, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79CWE-80

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card