CVE-2024-21686

HIGH
8.7
CVSS Score
Published: July 16, 2024 at 08:00 PM UTC
Updated: June 17, 2026 at 07:09 AM UTC
2 products affected across 1 vendorConfluence ServerConfluence Data Center

Using Confluence Data Center by Atlassian?

Get instant alerts when new vulnerabilities affect Confluence Data Center - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.7
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

This High severity Stored XSS vulnerability was introduced in versions 7.13 of Confluence Data Center and Server. This Stored XSS vulnerability, with a CVSS Score of 7.3, allows an authenticated attacker to execute arbitrary HTML or JavaScript code on a victims browser which has high impact to confidentiality, high impact to integrity, no impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions listed on this CVE See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives). This vulnerability was reported via our Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 7.19.227.19.0 ≤ v ≤ 7.19.217.19.22 ≤ v ≤ 7.19.257.20.0 ≤ v ≤ 7.20.37.20.0 ≤ v < 8.5.98.0.0 ≤ v ≤ 8.0.48.1.0 ≤ v ≤ 8.1.48.2.0 ≤ v ≤ 8.2.38.3.0 ≤ v ≤ 8.3.48.4.0 ≤ v ≤ 8.4.58.5.0 ≤ v ≤ 8.5.88.5.9 ≤ v ≤ 8.5.128.6.0 ≤ v ≤ 8.6.28.6.0 ≤ v < 8.9.18.7.1 ≤ v ≤ 8.7.28.8.0 ≤ v ≤ 8.8.18.9.1 ≤ v ≤ 8.9.47.19.07.19.227.20.08.0.08.1.08.2.08.3.08.4.08.5.08.5.98.6.08.7.18.8.08.9.08.9.1
Affected range stops below 7.19.22, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.19.22 to 7.19.25 (unaffected)
Affected range stops below 8.5.9, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8.5.9 to 8.5.12 (unaffected)
Affected range stops below 8.9.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8.9.1 to 8.9.4 (unaffected)
v < 7.19.227.19.0 ≤ v ≤ 7.19.217.19.22 ≤ v ≤ 7.19.257.20.0 ≤ v ≤ 7.20.37.20.0 ≤ v < 8.5.98.0.0 ≤ v ≤ 8.0.48.1.0 ≤ v ≤ 8.1.48.2.0 ≤ v ≤ 8.2.38.3.0 ≤ v ≤ 8.3.48.4.0 ≤ v ≤ 8.4.58.5.0 ≤ v ≤ 8.5.88.5.9 ≤ v ≤ 8.5.127.19.07.19.227.20.08.0.08.1.08.2.08.3.08.4.08.5.08.5.9
Affected range stops below 7.19.22, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.19.22 to 7.19.25 (unaffected)
Affected range stops below 8.5.9, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8.5.9 to 8.5.12 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card