CVE-2024-21685

MEDIUM
6.5
CVSS Score
Published: June 18, 2024 at 05:00 PM UTC
Updated: June 17, 2026 at 07:09 AM UTC
3 products affected across 1 vendorJira ServerJira Data CenterJira Core

Using Jira Core Data Center by Atlassian?

Get instant alerts when new vulnerabilities affect Jira Core Data Center - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

This High severity Information Disclosure vulnerability was introduced in versions 9.4.0, 9.12.0, and 9.15.0 of Jira Core Data Center. This Information Disclosure vulnerability, with a CVSS Score of 7.4, allows an unauthenticated attacker to view sensitive information via an Information Disclosure vulnerability which has high impact to confidentiality, no impact to integrity, no impact to availability, and requires user interaction. Atlassian recommends that Jira Core Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Jira Core Data Center 9.4: Upgrade to a release greater than or equal to 9.4.21 Jira Core Data Center 9.12: Upgrade to a release greater than or equal to 9.12.8 Jira Core Data Center 9.16: Upgrade to a release greater than or equal to 9.16.0 See the release notes. You can download the latest version of Jira Core Data Center from the download center. This vulnerability was found internally.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

9.12.0 ≤ v ≤ 9.12.79.12.0 ≤ v < 9.12.89.15.0 ≤ v < 9.16.09.4.0 ≤ v ≤ 9.4.209.4.0 ≤ v < 9.4.21
Affected range stops below 9.12.8, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.12.8 to 9.12.10 (unaffected)
Affected range stops below 9.16.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.16.0 to 9.16.1 (unaffected)
Affected range stops below 9.4.21, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.4.21 to 9.4.23 (unaffected)
95%
9.12.0 ≤ v < 9.12.89.4.0 ≤ v < 9.4.21
Affected range stops below 9.12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.4.21, so it looks safe — our inference, not a vendor statement
60%
9.12.0 ≤ v ≤ 9.12.79.4.0 ≤ v ≤ 9.4.209.12.09.4.0
Vendor states this is fixed in 9.12.8 (unaffected)
Vendor states this is fixed in 9.16.0 (unaffected)
Vendor states this is fixed in 9.4.21 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfoCWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card